Author Topic: UE4.14 - Odd height map behaviour of .sbsar file  (Read 942 times)

I was working on a landscape following the livestream recording "Substance in UE4: Creating Landscape Material" (https://www.youtube.com/watch?v=aFATxLO_rvQ) using my own material, and I ran into an issue. I'm fairly certain this could be a bug in the latest release in the Substance plug-in, but as this is my first time using a sbsar file directly through the plug-in in UE4, I might be wrong.

The issue is as follows. While combining the materials with a Landscape Layer Blend in the UE4 Material Editor, I needed to hook up a Height map mask. I hook up the Height Map and fix the Preview Weight. Which in the livestream fixes the issue with the black terrain and preview material. My material changes to the an appropriate color yet my material remains the same. Another differences I notice is the Height map in the Livestream has very solid whites and blacks, and no transparency.
In my height map, I see some form of transparency going on and it shows as a red in the UE4 Material Editor (see images below). Any ideas as to whether this is a bug or an issue on my side, and might anyone be able to provide solutions to this?

Edit: I did a quick test to see if the Height map appeared correctly in the UE4.10 Material Editor and it does so. I have not put it into a Landscape Material yet, but I find it likely there's something strange going on with the Substance Plugin in UE4.14 when it comes to height maps. I have yet to try and see if the issue arises in UE 4.13, 4.12 or 4.11.



Last Edit: January 27, 2017, 02:02:51 pm

I was working on a landscape following the livestream recording "Substance in UE4: Creating Landscape Material" (https://www.youtube.com/watch?v=aFATxLO_rvQ) using my own material, and I ran into an issue. I'm fairly certain this could be a bug in the latest release in the Substance plug-in, but as this is my first time using a sbsar file directly through the plug-in in UE4, I might be wrong.

The issue is as follows. While combining the materials with a Landscape Layer Blend in the UE4 Material Editor, I needed to hook up a Height map mask. I hook up the Height Map and fix the Preview Weight. Which in the livestream fixes the issue with the black terrain and preview material. My material changes to the an appropriate color yet my material remains the same. Another differences I notice is the Height map in the Livestream has very solid whites and blacks, and no transparency.
In my height map, I see some form of transparency going on and it shows as a red in the UE4 Material Editor (see images below). Any ideas as to whether this is a bug or an issue on my side, and might anyone be able to provide solutions to this?

Edit: I did a quick test to see if the Height map appeared correctly in the UE4.10 Material Editor and it does so. I have not put it into a Landscape Material yet, but I find it likely there's something strange going on with the Substance Plugin in UE4.14 when it comes to height maps. I have yet to try and see if the issue arises in UE 4.13, 4.12 or 4.11.





HI,

The image links seem to be broken. Can you please post the images again? Also, can you post your sbs file?

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

Strange. I can see the images. How about these?

Unreal Engine 4.14: https://drive.google.com/open?id=0B-BDI0mGIu_cYUdYV2U5U19ndTA
Substance Designer 5.6: https://drive.google.com/open?id=0B-BDI0mGIu_cM1hRN1ZwX1o3Sm8

Strange. I can see the images. How about these?

Unreal Engine 4.14: https://drive.google.com/open?id=0B-BDI0mGIu_cYUdYV2U5U19ndTA
Substance Designer 5.6: https://drive.google.com/open?id=0B-BDI0mGIu_cM1hRN1ZwX1o3Sm8

Thanks : ) That works. In Designer 2D view, the alpha channel is being viewed and there is data there. Can you post the sbs file? I can take a look.

Cheers,
wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

Strange. I can see the images. How about these?

Unreal Engine 4.14: https://drive.google.com/open?id=0B-BDI0mGIu_cYUdYV2U5U19ndTA
Substance Designer 5.6: https://drive.google.com/open?id=0B-BDI0mGIu_cM1hRN1ZwX1o3Sm8

Thanks : ) That works. In Designer 2D view, the alpha channel is being viewed and there is data there. Can you post the sbs file? I can take a look.

Cheers,
wes

Yeah, please do take a look, I might be making some beginner's mistake in Substance. Here is the file: https://drive.google.com/open?id=0B-BDI0mGIu_cOWRQaDBYR2VFTTQ

Strange. I can see the images. How about these?

Unreal Engine 4.14: https://drive.google.com/open?id=0B-BDI0mGIu_cYUdYV2U5U19ndTA
Substance Designer 5.6: https://drive.google.com/open?id=0B-BDI0mGIu_cM1hRN1ZwX1o3Sm8

Thanks : ) That works. In Designer 2D view, the alpha channel is being viewed and there is data there. Can you post the sbs file? I can take a look.

Cheers,
wes

Did you have a look at the sbs file?

Strange. I can see the images. How about these?

Unreal Engine 4.14: https://drive.google.com/open?id=0B-BDI0mGIu_cYUdYV2U5U19ndTA
Substance Designer 5.6: https://drive.google.com/open?id=0B-BDI0mGIu_cM1hRN1ZwX1o3Sm8

Thanks : ) That works. In Designer 2D view, the alpha channel is being viewed and there is data there. Can you post the sbs file? I can take a look.

Cheers,
wes



Did you have a look at the sbs file?


Hi,

I'm sorry for the delay. We are checking the file. Need to get some info from the devs. I'll report back ASAP.

Cheers,
wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja