Author Topic: Some controls (Tweaks, etc.) don't show up in the Substance Properties panel  (Read 186 times)

Hi - I'm using Modo Indie 10, and was doing my first Substance tests. I downloaded this material and attempted to add it to a test object in Modo, and while I see that I am successful at getting rust to show up, there are a whole bunch of missing controls. If you go to that materials page, one of the screenshots shows that there are a bunch of controls under "Scratches" (Show Scratches, Roughness, Amount, Scale, etc.) and a bunch of controls under "Rust" (Rust Amount, Scale, Normal, etc.), but in my Substance Properties panel, I see only a small subset of them. Note that I have no Tweak controls, a missing Rust Amount, and missing Scratches controls... and some of the Rust controls look duplicated.

So I do see that I have successfully gotten rust to show up, but it's pegged at 100% with no way for me to adjust it, and no way for me to turn on or adjust Scratches or whatever is supposed to be under Tweaks.

I've tried it with 3 other materials as well (Lead Rough, Aluminum Directional, and Metal Panels 001, and I don't see Tweaks for any of them - all I see are some basic parameters.

Any ideas? I am running with whatever Steam installed for me and is keeping up to date for Modo Indie 10 and the Substance for Modo DLC item.

Hi - I'm using Modo Indie 10, and was doing my first Substance tests. I downloaded this material and attempted to add it to a test object in Modo, and while I see that I am successful at getting rust to show up, there are a whole bunch of missing controls. If you go to that materials page, one of the screenshots shows that there are a bunch of controls under "Scratches" (Show Scratches, Roughness, Amount, Scale, etc.) and a bunch of controls under "Rust" (Rust Amount, Scale, Normal, etc.), but in my Substance Properties panel, I see only a small subset of them. Note that I have no Tweak controls, a missing Rust Amount, and missing Scratches controls... and some of the Rust controls look duplicated.

So I do see that I have successfully gotten rust to show up, but it's pegged at 100% with no way for me to adjust it, and no way for me to turn on or adjust Scratches or whatever is supposed to be under Tweaks.

I've tried it with 3 other materials as well (Lead Rough, Aluminum Directional, and Metal Panels 001, and I don't see Tweaks for any of them - all I see are some basic parameters.

Any ideas? I am running with whatever Steam installed for me and is keeping up to date for Modo Indie 10 and the Substance for Modo DLC item.


Hi,

There is an issue with the substance. The substance contains 2 graphs a metal and a rust. The rust is used in the metal and the metal is where you have the controls. However, I forgot to set the rust graph to not be visible as a separate material. You can do this in the attributes>Output computation = no.

When this is loaded into modo, you are seeing the rust graph which has different parameters. In the latest version of the modo plugin, you can select which graph you want to use in a substance. If you set it to metal, it will work fine. I have updated the source files so it now works as expected by default.

https://share.allegorithmic.com/libraries/239

You mentioned you are using modo indie. I was thinking that the substance plugin did not work in modo indie. It's working for you?

Cheers,
Wes

Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com

Hi! Thanks for the speedy response. I gave that new material a try and it works, as far as I can tell! I originally thought it was a general problem, not a material-specific problem because a few others that I tried (Lead Rough, Aluminum Directional, and Metal Panels 001) all didn't have tweak controls, but now that I am looking at them in Unity as well it looks like most of them simply don't have tweak controls.

Quote
You mentioned you are using modo indie. I was thinking that the substance plugin did not work in modo indie. It's working for you?

Yes, I think so. I can't quite get my materials to look the same in Modo as what I'm getting in Unity and what I see in the sample swatches on the allegro share site, but I'm pretty sure that's because I'm new to the Modo shading pipeline and I'm probably hooking something wrong up to something else (specular, metallic, roughness, smoothness, etc.). But yes, it appears to work, and Steam downloaded it automatically for me: http://i.imgur.com/h75DBpH.png

Hi! Thanks for the speedy response. I gave that new material a try and it works, as far as I can tell! I originally thought it was a general problem, not a material-specific problem because a few others that I tried (Lead Rough, Aluminum Directional, and Metal Panels 001) all didn't have tweak controls, but now that I am looking at them in Unity as well it looks like most of them simply don't have tweak controls.

Quote
You mentioned you are using modo indie. I was thinking that the substance plugin did not work in modo indie. It's working for you?

Yes, I think so. I can't quite get my materials to look the same in Modo as what I'm getting in Unity and what I see in the sample swatches on the allegro share site, but I'm pretty sure that's because I'm new to the Modo shading pipeline and I'm probably hooking something wrong up to something else (specular, metallic, roughness, smoothness, etc.). But yes, it appears to work, and Steam downloaded it automatically for me: http://i.imgur.com/h75DBpH.png

No problem : ) Please take a look at our docs. I have detailed sections on how the material setup works.
https://support.allegorithmic.com/documentation/display/integrations/MODO

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com