Author Topic: Maya 2018 Substance plugin not working reliably  (Read 646 times)

I am re-posting a question I've already asked but not yet received a reply to because I think this is the better heading. I don't know how to take an existing post and change the heading. So apologies to anyone who sees this twice:

I'm finding I can't rely on the Substance plugin to link to files in Maya 2018. I got it to work once with a substance that ships with Maya which I copied into the source images folder of my project. (I couldn't get that same substance to open by navigating to the substances folder created during the software installation.) I had no luck linking to two sbsar files I had created with Substance Designer no matter what folder I put them in. In some cases I could see the file name in the substance node window, but no outputs appeared. I've tried turning the plugin off and then on, but that didn't help.

So for now I have returned to Maya 2017, where these same substances do seem to link up. My question, of course, is whether I'm experiencing a bug or operator error.

Thanks for any advice.

I am re-posting a question I've already asked but not yet received a reply to because I think this is the better heading. I don't know how to take an existing post and change the heading. So apologies to anyone who sees this twice:

I'm finding I can't rely on the Substance plugin to link to files in Maya 2018. I got it to work once with a substance that ships with Maya which I copied into the source images folder of my project. (I couldn't get that same substance to open by navigating to the substances folder created during the software installation.) I had no luck linking to two sbsar files I had created with Substance Designer no matter what folder I put them in. In some cases I could see the file name in the substance node window, but no outputs appeared. I've tried turning the plugin off and then on, but that didn't help.

So for now I have returned to Maya 2017, where these same substances do seem to link up. My question, of course, is whether I'm experiencing a bug or operator error.

Thanks for any advice.

Hi,

Can you post the substances you are working with?

Cheers,
wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

If I remember correctly the version witch is shipping with Maya 2018 is an old one.
I think there is no updated Substance Plug-in for Maya 2018.


Wes, can you confirm this?


Cheers, D
I'm an Environment Artist and R&D Generalist at Digic Pictures

If I remember correctly the version witch is shipping with Maya 2018 is an old one.
I think there is no updated Substance Plug-in for Maya 2018.


Wes, can you confirm this?


Cheers, D


Hi,

Yes, that is correct. We haven't updated the plugin to Maya 2018 yet. We are working on that now.

Cheers,
wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

Is there an ETA and/or a beta we can use?

Is there an ETA and/or a beta we can use?

HI,

We don't have a beta. We are currently working on additional updates and features for the plugin. We will do our best to get the 2018 version released ASAP.

Cheers,
wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

Hi Wes,
Sounds good. Thanks for the update.
D
I'm an Environment Artist and R&D Generalist at Digic Pictures

Hi Wes,
Sounds good. Thanks for the update.
D

No problem : ) Very sorry for the delay on the plugin. We are making updates and adding some new features. Happy to say there will be a new preferences options for settings : ) I'll post more info as soon as I can.

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja