Author Topic: Undetailed texture in Unity  (Read 237 times)

Hi, :)

I textured a pencil mesh (found on thepixellab.net) in SP and put it into Unity, but the result is extremely different. Any idea what I did wrong?

Thank you in advance!


Vidal

No idea?  :-\ Should I be more specific?
 I used pbr-metal-rough as a shader, and I had a lot of [MapExport] like this, about opacity and emissive.

No idea?  :-\ Should I be more specific?
 I used pbr-metal-rough as a shader, and I had a lot of [MapExport] like this, about opacity and emissive.

Hi,

No issues with the warnings from Painter. They are just saying that the configuration file has emissive and opacity but the texture set doesn't have emissive and opacity. These are not needed.

The differences in the renders could mainly be the environment. If you are using the default Unity environment, there isn't much detail. Also, you need to add reflection probe. Another issue could be the Color Space setting in Player Settings. By default it's set to gamma which is incorrect for PBR. It needs to be set to linear.

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

No idea?  :-\ Should I be more specific?
 I used pbr-metal-rough as a shader, and I had a lot of [MapExport] like this, about opacity and emissive.

Hi,

No issues with the warnings from Painter. They are just saying that the configuration file has emissive and opacity but the texture set doesn't have emissive and opacity. These are not needed.

The differences in the renders could mainly be the environment. If you are using the default Unity environment, there isn't much detail. Also, you need to add reflection probe. Another issue could be the Color Space setting in Player Settings. By default it's set to gamma which is incorrect for PBR. It needs to be set to linear.

Cheers,
Wes

Hi Wes :)

Thanks for the reply!
Im set in Linear, and textures are fine with other meshes done with SP. I finally decided to create my own and now it works perfectly so maybe the issue was caused by the mesh itself.  ;)

Have a nice day,


Vidal

No idea?  :-\ Should I be more specific?
 I used pbr-metal-rough as a shader, and I had a lot of [MapExport] like this, about opacity and emissive.

Hi,

No issues with the warnings from Painter. They are just saying that the configuration file has emissive and opacity but the texture set doesn't have emissive and opacity. These are not needed.

The differences in the renders could mainly be the environment. If you are using the default Unity environment, there isn't much detail. Also, you need to add reflection probe. Another issue could be the Color Space setting in Player Settings. By default it's set to gamma which is incorrect for PBR. It needs to be set to linear.

Cheers,
Wes

Hi Wes :)

Thanks for the reply!
Im set in Linear, and textures are fine with other meshes done with SP. I finally decided to create my own and now it works perfectly so maybe the issue was caused by the mesh itself.  ;)

Have a nice day,


Vidal

Hi Vidal,

Ah, I see. Very glad to hear you have it resolved. Please let me know if you run into issues in the future.

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja