Author Topic: What's the latest regarding substance/marmoset compatibility?  (Read 882 times)

I have latest Substance Designer and Marmoset, when I load a sbsar into marmoset the exposed parameters are there but changing them doesn't make a difference. I'm guessing it's marmoset not being updated to the latest substance nodes, shame because my latest substance uses a few of em (such as floodfill). Just checking to make sure that's likely the issue here?

Anyone?

Hi,

I'm sorry for the delayed response. Toolbag is using the latest Substance Engine. Are you using a custom substance or a material from Substance Source? Would you be able to send me the substance ?

Cheers,
wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

Attached a sbsar, it's my own custom material. Not had time to fix some old exposed parameters but I know for sure the 'lath colour' one works perfectly in substance. So would be curious if you can get that parameter to work in Toolbag.

Still having issues with marmoset and substances. Today I put in a new sbsar I'm working on and it looks like a fabric carpet.


Still having issues with marmoset and substances. Today I put in a new sbsar I'm working on and it looks like a fabric carpet.



Hi,

Are you using the GPU or CPU Substance engine? This looks like it could be an issue of Marmoset using the CPU engine. The color you have exposed should be working. I checked the Wood_Lath graph. I added it to a new graph, exposed the parameters for the node and the parameters appeared and worked in Toolbag. The only parameter that doesn't work is the Random Seed value.

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja