Author Topic: Displacement stepping - bit depth?  (Read 1179 times)

Hi - I'm testing the ace new landscape substances in Cinema, Standard Renderer and RedShift - and noticing nasty stepping in the displacements, see pic. I'm guessing this is a result of baking the texture at 8-bit, is there a way to force the engine to work at 16-bit or preferably float values? Or, if this isn't the issue, is there a way to get clean displacement?

Thanks in advance! Chris

Hey isn't there nan option to switch the engine in GPU/16 bits mode in C4D?

Hi Vincent - thanks for the reply. There's no bit-depth option that I can see for Cinema, just resolution 256 -> 2048. I'll ask around and see if there's something I'm missing.

Cheers - Chris

I'll ask to the team.

Hi Vincent - thanks for the reply. There's no bit-depth option that I can see for Cinema, just resolution 256 -> 2048. I'll ask around and see if there's something I'm missing.

Cheers - Chris

Hi Chris,

We don't handle the C4D integration. However it sounds like you just need to switch the engine to GPU. You should have a setting to switch the substance engine from CPU to GPU.

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

Hi Vincent - thanks for the reply. There's no bit-depth option that I can see for Cinema, just resolution 256 -> 2048. I'll ask around and see if there's something I'm missing.

Cheers - Chris

Hi Chris,

We don't handle the C4D integration. However it sounds like you just need to switch the engine to GPU. You should have a setting to switch the substance engine from CPU to GPU.

Cheers,
Wes

HI,

I spoke with the Maxxon devs and currently they use the fallback to 8 Bit in Substance Engine.

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

Thanks for chasing this up Wes, much appreciated. I used your advice about switching engine though, from SSE2 to DirectX11, which unlocked the higher resolutions, and at 4k the stepping is much less offensive. I've also added a sprinkle of high-frequency noise and the steps are effectively gone.

Any way you cut it though, getting rock formations like these by chucking a material onto a low-poly torus is pretty insane - congratulations on the latest source additions, very impressive!


Just a quickie follow up for anyone else who might be running into this, with RedShift in particular, try disabling 'auto bump' in the displacement/height options, it helps smooth things out quite nicely.