Author Topic: Substance source .sbsar shader not working in maya 2018 with plugin  (Read 991 times)

Hi there,
I'm relatively new to substance. i downloaded desert_sandy_bedrock.sbsar from the substance source library's signature collection. I was able to use it without issue in modo. However, when I try to bring it into maya 2018 using the substance plugin, it is not loading the shader or the maps at all. I set the workflow to custom and made sure that the automatic connections was clicked on. when i try to open that shader nothing happens. No maps are generated and the substance file input box stays empty. I tried using one of the materials that came with the substance plugin called corrugated_Metal.sbsar and that came in and propogated fine. I'm not sure what I'm missing?? Please advise.
Dominika

I'm having a similar issue, and one that I see described in a number of forum threads. As described by the OP, a working SBSAR file is loaded by the Maya LT 2018 Substance Plugin inside Hypershade (plugin version 1.2.4.0-bb5eb94 in my case), and nothing updates or responds to clicks. Sometimes the "Reload" button will add the absolute path to the substance name.

No inputs are shown in the window area below the "Reload" button. Pressing "Create shader network" creates an error popup that says "No Substance Output Node could not be automagically connected to the shader node. Pleasemanually [sic] connect the output to the appropriate shaderinput or exit custom workflow". Side note: the popup mentions "custom workflow" even while in "StingrayPBS" workflow, and actually the "Create shader network" button is not available in the "Custom" workflow.

A handful of downloaded files from Substance Source work, but not all, and none of my custom Designer files do (they all use the standard metallic PBR outputs from the included template, some with AO).

Any advice on what the specific requirements are for the plugin would be appreciated. Also, since I was only trying this because I thought it might be easier than creating new basic materials and loading the basecolor/diffuse maps to do some model tweaks (e.g. no baking or rendering or anything that actually needs the full PBR material), would it be better to skip the plugin entirely?

Thanks

Hi,

I'm sorry for this issue. We will take a look at the source files in question to see what is causing the problem. The maya plugin is thinking that the identifier field is not right. The issue is that some source sbsar files have an output that the maya plugin can't read so it's not reading any of the outputs.

We are investigating this issue.

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

Hello, I have the same issue. We have Maya 2018.3 and I updated the substance plugin to the latest version. I am trying to load the *.sbsar files that come with Maya. It does not work!? The only file that is connected is the normal map. Currently I am doing a tutorial from plurasight and in 2012 it worked. All sbsar files from the Maya folder are not working. I tested it in Maya 2017 as well, same thing, not working. Is there any solution to it? We are really interested in testing substance but we can not test it :(

it is also not possible to set the Workflow in the substance loader, I see the drop down menu but no text? strange thing
Last Edit: June 26, 2018, 03:26:54 pm

Hello, I have the same issue. We have Maya 2018.3 and I updated the substance plugin to the latest version. I am trying to load the *.sbsar files that come with Maya. It does not work!? The only file that is connected is the normal map. Currently I am doing a tutorial from plurasight and in 2012 it worked. All sbsar files from the Maya folder are not working. I tested it in Maya 2017 as well, same thing, not working. Is there any solution to it? We are really interested in testing substance but we can not test it :(

it is also not possible to set the Workflow in the substance loader, I see the drop down menu but no text? strange thing

I think this is all caused by a bug we are looking into. We are going to be revisiting this plugin soon with a new full rewrite coming as well. Can you give me the name of the Substance Source file you are trying to use?

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

Hi, I was trying to to load BrickWall_03.sbsar, but none of the materials in the substances folder is working. We tried this here in the office on another computer and it did not work either. At home it is working, I installed Maya as a demo version without updating the substances plugin and all the substances sbsar files are working. Maya is doing all the connections for the materials. strange thing. Here in the office we have the GTX 1080 Ti and home I have the GTX 960. No clue if it has to do with the graphics card. I will try it again with a fresh user Maya folder. Perhaps some prefs are rubish

Now it worked, I had to choose the right workflow in the drop down menu of the substance material. But we can not see types of workflows?

Last Edit: June 28, 2018, 12:10:36 pm

Hi,

We are looking into this issue. It's hard to reproduce as it seems to happen randomly. It's something with internal selection of the substance node. As a workaround, you can deselect the substance node in the node editor, then reselect it and you should then see the substance parameters load in the Attribute Editor or Property Editor (Hypershade).

Another workaround is to close and restart maya. You should then be able to load the substance without issue. We are working on this bug.

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja