Author Topic: 3D Viewport lighting is static  (Read 305 times)

When i'm viewing my material in the 3D window in designer i can rotate the camera ok, but there is no way to do anything to the light, it remains static. I added the light debug display, and the line is rotating alright but nothing happens with the actual light... I have ambient + point1+point 2 enabled. Also enabled/disabled them, changed intensity -> no effect. Tried different materials and environments and shaders, light remains static. I reset everything there was to reset in the 3D window, no sauce. What's wrong? I know it worked a few months ago when i used designer last ?

I just updated to 2018.1.1 but i don't remember if that was what caused it...

Hi,

Can you try to display your background (Environment > Edit > "Is Visible" set to true)  and press CTRL + Shift + Right Mouse Button ? The environment map is supposed to rotate.

Can you also try to set your lights this way ?



And press SHIFT + Left Mouse Button in your 3Dview ?

Q.A Analyst

The environment displays and rotates ok. The light from the environment goes along with it.

But the point lights do not work whatsoever. And changing the ambient light settings doesn't do anything either.
The p1 light is enabled, red, intensity 10 in the settings:



Can you please try to set your environment map exposure to -10 ? (Environment > Edit)
You can also disable the background.




There is no ambient light while working with PBR shaders as the ambient light color is a way to fake your environment map behavior (the ambient light is an average of your environment map information).

If you want to have a look to it, you can switch to a blinn shader.
Q.A Analyst

Oh i thought the ambient would control light coming from the environment. Didn't know they are separate things.
When i set env map exposure to -10 i get a pitch black scene, no light whatsoever from the point light
Last Edit: May 17, 2018, 06:03:06 pm

Try to set another color than the default one (which is fully black).  :)
Q.A Analyst

Hello Luc,
there was a material applied. It is pitch black no matter what material or color is applied (with environment exposure all the way down and point lights enabled and at maximum intensity).
Other people seem to have the same problem https://forum.allegorithmic.com/index.php/topic,13517.0.html

If you want it, we can do a team viewer session together.

Just send me a PM so we can plan it.
Q.A Analyst