Author Topic: Linux Users: Debian and Ubuntu  (Read 3793 times)

So, the current package they are using is RPM.  If you don't know how, here is how to get it working under a Debian/Ubuntu Distro.  This isn't officially supported I take it at this time, so user beware.  I already noticed a bug in the viewer when moving the object, that might be Linux in general or specific to the Nvidia Ubuntu Drivers.

Terminal
sudo apt-get update
sudo apt-get install alien
....

cd /home/your user/(where you downloaded the rpm substance package.
sudo alien --scripts Substance_Designer-5.5.0-1.el6.standard.full.x86_64.rpm

....
It will take about 3 minutes to convert.

....

sudo dpkg -i substance-designer_5.5.0-2_amd64.deb
sudo Substance_Designer  *

*You have to run it as admin as it won't make the directories otherwise.

Also OGL 2.01??? Really guys?  Just because Apple is stuck in the past doesn't mean the rest of the OGL world should be!

Thanks man! exactly what I needed  8)

hope rest of the stuff work more straight!
Last Edit: December 02, 2016, 12:13:05 am

What about for Substance Painter?

bvz


Just fyi for anyone else trying this.  Do not run the last command as sudo:


i.e. don't do this:
Code: [Select]
sudo Substance_Designer  *
Instead, run it normally.

Code: [Select]
Substance_Designer  *
If you run it as sudo, then all of the local directories in your home dir will be owned by root instead of you and you will not be able to save your files or save your preferences.

If you DO run it using sudo, it can be fixed after the fact.

Go to your home directory, and then your Documents directory:

Code: [Select]
cd
cd Documents

Then change the ownership of the Allegorithmic directory and all of its children to you

Code: [Select]
sudo chown -R Allegorithmic <your user name here>
sudo chgrp -R Allegorithmic <your user name here>

Note, you must insert your own user name above where it says <your user name here>

Next, go to your local, hidden preferences directory

Code: [Select]
cd
cd .local/share/

Then change the ownership of these files too:

Code: [Select]
sudo chown -R Allegorithmic <your user name here>
sudo chgrp -R Allegorithmic <your user name here>


That should be enough to get it to run.

I had to also open the preferences, and add the following paths to the Projects -> General tab:

file:///opt/Allegorithmic/Substance_Designer/resources/templates

in order to get it to load all of the libraries.

Hi,

I tried this with the last version of the rpm package "Substance_Designer-2018.2.1-1495-linux-x64-standart-full.rpm". First steps works well, but when I type the command Substance_Designer it's return to me what it don't find the command. I'm bit noob on linux (I use Linux Mint since 2 month), any idea where that could come from ?

Thank's in advance

I am just copying the extracted .rpm package into opt folder and run the app(Designer and Painter) and add to favorite manually or by using Menu Editor
I found that if the preferences not saving you need to change the permission on the file.
and if the qt file dialog(file open save) refuse to save bookmark, change/edit the preference but I can't remember where it is located.

Starting with 20018.2.0 the UI is pleasant to use and the "Alt+RMB" for zoom in/out is working, the floating Node Toolbar is really floating even if the main app minimized and not really an issue for me, the ability to zoom in and out smoothly is more important with small screen.
And if the baker window going off screen for display under 800px height just grab the window with "Alt+F7" to bring it a little bit upward to have that bake button visible.

I don't have the OGL 2.0 when I try to switch engine, it says OGL 3.x in the dialog.